ВходНаше всё Теги codebook PARTS Поиск Опросы Закон Четверг
21 января
/1054425
Топик полностью
AVF (22.11.2020 15:43, просмотров: 110) в ответ на Поломалась отладка в STM32SW4 (eclipse). Подскажите куда копать. Уже два раза все удалил и заново переставил (SW4, драйверты и сервер stlink разные версии) с перезагрузкой, весь доступ и порты в файрволле проверил, не работает. Причем с неделю назад, со второго-третьего раза подключался, вчера вообще перестал. ST-Link через STVP и из SW4 контроллер и пишет и читает и стирает. Настройки правильные т.е. (software reset, с разными скоростями пробовал). Тот же проект, тот - автор: AVF
update - пока не решил, но проблема в gdb+ОС. Переустановка SW4, разных версий драйверов, установка Atollic True Studio, STM32CubeIDE (все на базе эклипса), удаление антивируса/файрвола (avast), не помогли, хотя антивирус и на ноутах стоит. Отладка из Keil работает (и через STLink и через ULink), STM32CubeIDE позволяет работать через JLink - тоже не работает, на том же этапе - gdb не подключается. При этом пока запущен openocd, gdb из консоли windows подключается к openocd и 

к мк. Единственно отличие от ноута Win10 2004, а на ноутах 1909. К сожалению откатить не могу, перед этим удалил архивы старой версии. Гугл тоже помочь не может, видимо проблема чисто в оси. Но в чем именно, непонятно (порты проверил, да и из отдельно запущенный из консоли винды gdb работает и подключается к мк). Как будто IDE теряет доступ к консоли gdb после запуска, но как это происходит и как с этим бороться, непонятно.

Ответить
Ответы